路由器做NAT的方法和步骤

狒狒 发布于2013-6-26 16:5:0 分类: 网络技术 已浏览loading 网友评论27条 我要评论

      最近有一个新技术问我“路由器不是设置了账号密码连电脑就直接能上网了嘛?”我听后忽然明白这哥们可能是调家用路由器调的比较多,确实家用路由器只需要跟着配置向导调试就可以了,但是一般公司里面接触的Cisco、H3C或者华为的路由器一般还都是在命令行下调试,今天狒狒跟大家聊一下命令行下路由器的调试方法和步骤。

image

      准备工作:一台路由器、一个公网IP地址(公网IP、掩码、网关)

      路由器简单调试上互联网一般有这么几个步骤:

      1、进入路由器内外网接口分别开启接口,新手容易忘记这一个;

      2、分别给路由器内外网口设置IP地址;

      3、设置下一跳,也就是公网地址的网关;

      4、设置访问控制列表;

      5、设置NAT;

      一般设置路由器做NAT上互联网一般这5个步骤就够了,具体配置如下:

Router#show run
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
!
!
!
!
memory-size iomem 15
ip subnet-zero
!
!
!
!
interface Ethernet1/0
ip address 202.103.24.68 255.255.255.0
ip nat outside
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
ip address 192.168.5.1 255.255.255.0
ip nat inside

!
ip nat inside source list 2 interface Ethernet1/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 202.103.24.67
no ip http server
!
access-list 2 permit 192.168.5.0 0.0.0.255
!
line con 0
transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end

Router#

      红色标出来的就是需要配置的几条命令,很简单,可能大部分人还是对基础知识不是很明白或者有些命令不熟悉导致他们配置出问题,建议学习路由交换的同学可以多配置几次,多熟练一下,这个配置是比较常见也是经常会用到的,下次狒狒再跟大家聊一下ADSL拨号如何设置。

你对 "路由器做NAT的方法和步骤" 有什么观点?请留言与我们分享。

原创文章转载请注明引自狒狒博客 http://www.feifeii.com/ 欢迎订阅狒狒博客

看图读文

  1. 这位小朋友蹲在海底27米处游来游去 中山婚纱摄影 回复该评论
    发表于2016-6-17 15:25:24

    学习一下

  2. 这位小朋友蹲在海底26米处游来游去 弘新教育 回复该评论
    发表于2015-4-10 9:34:22

    这个回家可以试试!

    狒狒 于 2015-4-10 15:24:29 回复
    试试吧,有不明白的地方可以给我留言!

  3. 这位小朋友蹲在海底25米处游来游去 企业文化标语 回复该评论
    发表于2014-3-28 15:06:48

    学习分享

  4. 这位小朋友蹲在海底24米处游来游去 emehost 回复该评论
    发表于2014-3-21 10:23:42

    挺详细的内容,学习一下

  5. 这位小朋友蹲在海底23米处游来游去 东方CJ 回复该评论
    发表于2014-3-13 11:34:34

    很喜欢这种表达方式。。。

  6. 这位小朋友蹲在海底22米处游来游去 企业文化标语 回复该评论
    发表于2014-3-6 16:15:36

    努力中,加油!

  7. 这位小朋友蹲在海底21米处游来游去 博客互推联盟 回复该评论
    发表于2014-3-5 15:57:13

    看到博主分享这么多内容,特别想把这些内容让更多博友看到,如果博主能够经常跟其他博友互动,希望博主能够加入到“博客互推联盟”,这里有很多很勤奋的博友,和您一样,每天在坚持为大家分享好的内容。
    在这个互联网快速变革的时代,我们还在坚持,但我们不想孤军奋战,让更多博友看到你,让我们彼此多一点交流,一起发展。

  8. 这位小朋友蹲在海底20米处游来游去 银基网 回复该评论
    发表于2014-2-8 10:05:59

    年后初访,表示支持

  9. 这位小朋友蹲在海底19米处游来游去 Dh 回复该评论
    发表于2014-1-21 10:43:17

    收藏,虽然现在不用

  10. 这位小朋友蹲在海底18米处游来游去 adtask 回复该评论
    发表于2013-12-19 11:52:49

    来踩了,挺好的,加油

  11. 这位小朋友蹲在海底17米处游来游去 adtask 回复该评论
    发表于2013-12-18 22:22:58

    来踩了,挺好的,加油

  12. 这位小朋友蹲在海底16米处游来游去 银基网 回复该评论
    发表于2013-12-17 14:32:26

    初来乍到,支持下

  13. 这位小朋友蹲在海底15米处游来游去 如何减肥 回复该评论
    发表于2013-11-13 15:14:55

    真给力

  14. 这位小朋友蹲在海底14米处游来游去 西力士 回复该评论
    发表于2013-10-25 14:04:23

    第一次来,看一看

  15. 这位小朋友蹲在海底13米处游来游去 www.356688.com 回复该评论
    发表于2013-9-25 10:49:26

    能坚持写博客,至少也是个有恒心的人,赞一个
    癸巳年(蛇)八月廿一 2013-9-25

  16. 这位小朋友蹲在海底12米处游来游去 stepdrillbits 回复该评论
    发表于2013-8-25 12:41:50

    给力!欢迎回访!

  17. 这位小朋友蹲在海底11米处游来游去 stepdrillbits 回复该评论
    发表于2013-8-25 12:34:55

    博主勤奋更新,不错!

  18. 这位小朋友蹲在海底10米处游来游去 www.bring.com.cn 回复该评论
    发表于2013-8-16 14:19:33

    这个要了解下了

  19. 这位小朋友蹲在海底9米处游来游去 加密软件 回复该评论
    发表于2013-8-16 14:18:15

    谢谢分享,网站不错!

  20. 这位小朋友蹲在海底8米处游来游去 经典语录 回复该评论
    发表于2013-8-9 12:47:01

    这个要了解下了

  21. 这位小朋友蹲在海底7米处游来游去 媛诺诺 回复该评论
    发表于2013-7-25 17:11:17

    突然发现你博客是asp程序的?

  22. 这位小朋友蹲在海底6米处游来游去 28心理 回复该评论
    发表于2013-7-15 12:55:12

    这个要了解下了

  23. 这位小朋友蹲在海底5米处游来游去 奇闻猎奇 回复该评论
    发表于2013-7-13 7:42:37

    拜访,谢谢博主分享!欢迎来小站坐坐!

  24. 这位小朋友蹲在海底4米处游来游去 青岛婚纱摄影 回复该评论
    发表于2013-7-6 17:47:36

    Love不错嘛

  25. 这位小朋友蹲在海底3米处游来游去 Harid 回复该评论
    发表于2013-6-30 22:35:13

    介绍得很好!我现在也在慢慢地学习这些东西,主机、路由器、交换机等等

  26. 这位小朋友蹲在海底2米处游来游去 真实灵异 回复该评论
    发表于2013-6-29 13:36:25

    谢谢分享,网站不错!也欢迎您来访!

  27. 这位小朋友蹲在海底1米处游来游去 原梓番 回复该评论
    发表于2013-6-26 21:18:22

    看了这么多博客,楼主的博客更新算是很勤的了
    欢迎回访哦~

记住我的信息,下次不用再输入